Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved Can not Send Mail
#1
Hi There,
It is perfect open software but i have an issues.
Can not Send Mail "mail(): SMTP server response: 501 5.1.3 Invalid address"
Please help me fix it
Reply
#2
Hi bkpro,
It's seems that something in your mail configuration isn't correct, have you setup your mail details in: Config -> System -> Application -> Email ?

let me know if I can help you further
Reply
#3
Hi Paolo,
Thank you for your response, I get error "mail(): SMTP server response: 501 5.1.3 Invalid address" when i finish do as following steps and update one task have Notification Email.

Config -> System -> Application -> Email
Email Parameter
--Admin Email: abc@xyz.com
--Subject Prefix Email: IT Team
--Method: PHP

SMTP Configuration
--SMTP Server: mail.xyz.com
--SMTP Port:25
--SMTP Encryption:587
--SMTP Login:abc
--SMTP Password:abc

Please help me.
Reply
#4
Hi bkpro,
try to change in Email Parameter, the Method from PHP to SMTP

Tell me if works,
Paolo
Reply
#5
Hi Paolo
I did and getting error Mail Swift...
Reply
#6
(06-24-2015, 06:56 AM)bkpro Wrote: Hi Paolo
I did and getting error Mail Swift...

Ok I think we need to investigate better on this, can you please send via PM access to your myt installation with a demo admin account ?
Reply
#7
I did, could you please check PM and find out reason.
Thank you for your support.
Reply
#8
Hi bkpro,
Thank you for your PM, we found the issue, this is caused by an incompatibility between PHP5.5 and our mail library: PHPSwift.
We will include an updated version of the library in the next release, for the moment you can manually fix the problem by modifying the following file:

Open file: /protected/extensions/yii-mail/vendors/swiftMailer/classes/Swift/ByteStream/AbstractFilterableInputStream.php
Search:
PHP Code:
/** Write sequence */
  
private $_sequence 0

Replace with:
PHP Code:
/** Write sequence */
  
protected $_sequence 0

Thank your for your report,
Paolo
Reply
#9
(06-25-2015, 09:52 AM)Paolo Wrote: ỲHi bkpro,
Thank you for your PM, we found the issue, this is caused by an incompatibility between PHP5.5 and our mail library: PHPSwift.
We will include an updated version of the library in the next release, for the moment you can manually fix the problem by modifying the following file:

Open file: /protected/extensions/yii-mail/vendors/swiftMailer/classes/Swift/ByteStream/AbstractFilterableInputStream.php
Search:

PHP Code:
 /** Write sequence */
 
 private $_sequence 0

Replace with:

PHP Code:
 /** Write sequence */
 
 protected $_sequence 0

Thank your for your report,
Paolo

Hi paolo,
Thank you for your response, i think it can fix my issues. I do search and finding same your comment. But i dont know fix on which file.
I will report to you late
Thank you so much
Reply
#10
Dear Paolo,
I did try many way to get it but i get following fail.

1. fsockopen(): unable to connect to 587://mail.libertyhotels.com.vn:25 (Unable to find the socket transport "587" - did you forget to enable it when you configured PHP?)

2. change to PHP: mail(): SMTP server response: 501 5.1.3 Invalid address
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)