Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Missing site/login
#2
Hi Conrad!

Glad to see you here!

Regarding your problem can you post here ( or send via email ) your /etc/apache2/httpd.conf ? is this your first installation on mavericks of a php application that use .htaccess?

Anyway a temporary workaround while we are investigating on your problem open with a text editor the myt config file located at: /myt/protected/config/main.php


find the follwing lines:
PHP Code:
       'urlManager' => array(
 
           'urlFormat' => 'path',
 
           'showScriptName' => false,
 
           'rules' => array(
 
               '<controller:\w+>/<id:\d+>' => '<controller>/view',
 
               '<controller:\w+>/<action:\w+>/<id:\d+>' => '<controller>/<action>',
 
               '<controller:authItem>/<action:\w+>/<id:(?:[a-zA-Z0-9]+[ ]?)+[a-zA-Z0-9]+>' => '<controller>/<action>'//this is only for auth manager
 
               '<controller:\w+>/<action:\w+>' => '<controller>/<action>',
                
'<controller:charge>/<action:create>/<month:[\w-]+>/<user:\d+>/<project:\d+>' => '<controller>/<action>'//custom rule for months
 
           ),
 
       ), 

and comment out that lines:
PHP Code:
        /* -- REWRITE URL --
        'urlManager' => array(
            'urlFormat' => 'path',
            'showScriptName' => false,
            'rules' => array(
                '<controller:\w+>/<id:\d+>' => '<controller>/view',
                '<controller:\w+>/<action:\w+>/<id:\d+>' => '<controller>/<action>',
                '<controller:authItem>/<action:\w+>/<id:(?:[a-zA-Z0-9]+[ ]?)+[a-zA-Z0-9]+>' => '<controller>/<action>', //this is only for auth manager
                '<controller:\w+>/<action:\w+>' => '<controller>/<action>',
                '<controller:charge>/<action:create>/<month:[\w-]+>/<user:\d+>/<project:\d+>' => '<controller>/<action>', //custom rule for months
            ),
        ),
        -- REWRITE URL -- */ 


now your myt should be avaiable to localhost/myt/index.php

Let us know!
Reply


Messages In This Thread
Missing site/login - by conrad_myt - 09-24-2014, 10:27 PM
RE: Missing site/login - by Paolo - 09-24-2014, 10:40 PM
RE: Missing site/login - by conrad_myt - 09-24-2014, 11:34 PM
RE: Missing site/login - by Paolo - 09-25-2014, 10:16 PM
RE: Missing site/login - by mzucker - 10-31-2014, 03:47 AM
RE: Missing site/login - by Paolo - 10-31-2014, 10:29 PM
RE: Missing site/login - by mzucker - 10-31-2014, 11:23 PM
RE: Missing site/login - by Paolo - 11-01-2014, 11:28 AM

Forum Jump:


Users browsing this thread: 1 Guest(s)