Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error 500 file upload [Solved]
#1
Hi,

I get a « Error 500 unlink(/images/user/1410913747_ronzed.png): No such file or directory » when trying to upload an avatar.

I also get a similar message [move_uploaded_file(/attachments/ronzed.png): failed to open stream: No such file or directory] when uploading (an failing) a attachment to a task.

I tried to upload files on our hosted site and on virtual machine (Ubuntu 14.04, with full access) without success.

In Config > Application > Attachments
  • I checked to enable box
  • « Local »
  • Path  = /attachments
  • Size = 3200
  • Allowed Extensions = jpg, png, doc, docx, odf, ods, odp, pdf, xls, xlsx

Thanks.
Reply
#2
Hi dboisvert,
It seems that someone manually deleted this files from your folders, can you check that your old avatar exists on this path: /images/user/1410913747_ronzed.png and attachment to this path: attachments/ronzed.png ??

Anyway the first error should't be shown if old avatar is not found, so we will prevent the showing of that error on next release, thank you for your report!

Paolo
Reply
#3
Hm, initial upload of the avatar didn't work. I manually copied it to /images/user/. Shouldn't have done that I suppose.

Upload of files doesn't work at all. I always get an Error 500 message.

Tested on :
1. Chrome (version 37.0.2062.120 on Ubuntu 14.04, 64-bit).
2. Firefox (version 32.0 on Ubuntu 14.04, 64-bit). It doesn't work.
3. Chrome for Android (version 37.0.2062.117, Android 4.4.4; Nexus 4 Build/KTU84P).

Don't hesitate to ask if you need more info.
Reply
#4
Hi dboisvert,
ok restore all your images ( for not showing the error during the "deleting" phase )
then go with your browser in your myt installation --> Config --> Application --> "Avatar" tab and chage the Avatar Path to: images/user/ ( remove the first slash ).
with this modification upload should work.
Do the same with Attachments and change path to attachments ( without the first slash ).


Tell me if works
Reply
#5
Hi Paolo,

Thank's, it worked.

Dominic
Reply
#6
Ok nice Dominic, thank you for using MyT!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)