Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved New User
#1
Good Evening.
When I try to create a new user this message appears to me:

Error 500

CDbCommand ha riportato un errore nell'esecuzione della query SQL: SQLSTATE[22007]: Invalid datetime format: 1292 Incorrect datetime value: '2016-07-55 22:44:55' for column 'created' at row 1

...and the log message report this:

CDbException: CDbCommand ha riportato un errore nell'esecuzione della query SQL: SQLSTATE[22007]: Invalid datetime format: 1292 Incorrect datetime value: '2016-07-55 22:44:55' for column 'created' at row 1 in C:\wamp\www\TMSPMOCOOP\framework\db\CDbCommand.php:358
Stack trace:
#0 C:\wamp\www\TMSPMOCOOP\framework\db\ar\CActiveRecord.php(1080): CDbCommand->execute()
#1 C:\wamp\www\TMSPMOCOOP\framework\db\ar\CActiveRecord.php(809): CActiveRecord->insert(NULL)
#2 C:\wamp\www\TMSPMOCOOP\protected\models\User.php(250): CActiveRecord->save()
#3 C:\wamp\www\TMSPMOCOOP\protected\models\User.php(180): User->associateUserToChargeProjects()
#4 C:\wamp\www\TMSPMOCOOP\framework\db\ar\CActiveRecord.php(1100): User->afterSave()
#5 C:\wamp\www\TMSPMOCOOP\framework\db\ar\CActiveRecord.php(809): CActiveRecord->insert(NULL)
#6 C:\wamp\www\TMSPMOCOOP\protected\controllers\UserController.php(105): CActiveRecord->save()
#7 C:\wamp\www\TMSPMOCOOP\framework\web\actions\CInlineAction.php(49): UserController->actionCreate()
#8 C:\wamp\www\TMSPMOCOOP\framework\web\CController.php(308): CInlineAction->runWithParams(Array)
#9 C:\wamp\www\TMSPMOCOOP\framework\web\filters\CFilterChain.php(133): CController->runAction(Object(CInlineAction))
#10 C:\wamp\www\TMSPMOCOOP\framework\web\filters\CFilter.php(40): CFilterChain->run()
#11 C:\wamp\www\TMSPMOCOOP\framework\web\CController.php(1145): CFilter->filter(Object(CFilterChain))
#12 C:\wamp\www\TMSPMOCOOP\framework\web\filters\CInlineFilter.php(58): CController->filterAccessControl(Object(CFilterChain))
#13 C:\wamp\www\TMSPMOCOOP\framework\web\filters\CFilterChain.php(130): CInlineFilter->filter(Object(CFilterChain))
#14 C:\wamp\www\TMSPMOCOOP\framework\web\CController.php(291): CFilterChain->run()
#15 C:\wamp\www\TMSPMOCOOP\framework\web\CController.php(265): CController->runActionWithFilters(Object(CInlineAction), Array)
#16 C:\wamp\www\TMSPMOCOOP\framework\web\CWebApplication.php(282): CController->run('create')
#17 C:\wamp\www\TMSPMOCOOP\framework\web\CWebApplication.php(141): CWebApplication->runController('user/create')
#18 C:\wamp\www\TMSPMOCOOP\framework\base\CApplication.php(184): CWebApplication->processRequest()
#19 C:\wamp\www\TMSPMOCOOP\index.php(22): CApplication->run()
#20 {main}
REQUEST_URI=/TMSPMOCOOP/user/create
HTTP_REFERER=http://localhost:8888/TMSPMOCOOP/user/create

Can anyone help me?

Thanks
Francesco
Reply
#2
Hi Francesco,
Thank you for your bug report.

We have fixed this issue and will be avaiabile in the next MyT release.

Meanwhile you can patch your MyT installation by uploading this following two files:


.php   UserProject.php (Size: 6.33 KB / Downloads: 2)
Upload at path: /<your myt installation>/protected/models/



.php   ETimestampBehavior.php (Size: 7.94 KB / Downloads: 1)
Upload at path: /<your myt installation>/protected/behaviors/


Paolo
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)